<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<meta property="fb:app_id" content="748756371893770" />
	<title>Why the March for Our Lives will be a missed opportunity | The Right Way</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://johnfloyd.bangordailynews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
	<link rel='dns-prefetch' href='//johnfloyd.bangordailynews.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Right Way &raquo; Feed" href="https://johnfloyd.bangordailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Right Way &raquo; Comments Feed" href="https://johnfloyd.bangordailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Right Way &raquo; Why the March for Our Lives will be a missed opportunity Comments Feed" href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/johnfloyd.bangordailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://johnfloyd.bangordailynews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='https://johnfloyd.bangordailynews.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013_expert_parent-css'  href='https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/style.css?ver=2016-08-16' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013-expert/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/bdn-plugins/js/audience.js?ver=14'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/bdn-plugins/js/jwplayer-listener.js?ver=20170410.1'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/bdn-plugins/js/youtube-listener.js?ver=20170410.1'></script>
<link rel='https://api.w.org/' href='https://johnfloyd.bangordailynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://johnfloyd.bangordailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://johnfloyd.bangordailynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Why banning bump stocks in Maine is a fraud' href='https://johnfloyd.bangordailynews.com/2018/02/26/home/bump-stocks-are-the-new-red-herring-of-school-safety-failures/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel="canonical" href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" />
<link rel='shortlink' href='https://wp.me/p8iHsI-2r' />
<link rel="alternate" type="application/json+oembed" href="https://johnfloyd.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjohnfloyd.bangordailynews.com%2F2018%2F03%2F23%2Fhome%2Fwhy-the-march-for-our-lives-will-be-a-missed-opportunity%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://johnfloyd.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjohnfloyd.bangordailynews.com%2F2018%2F03%2F23%2Fhome%2Fwhy-the-march-for-our-lives-will-be-a-missed-opportunity%2F&#038;format=xml" />
	<script>(function() { var _fbq = window._fbq || (window._fbq = []); if (!_fbq.loaded) { var fbds = document.createElement('script'); fbds.async = true; fbds.src = '//connect.facebook.net/en_US/fbds.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(fbds, s); _fbq.loaded = true; } _fbq.push(['addPixelId', '413375698823720']); })(); window._fbq = window._fbq || []; window._fbq.push(['track', 'PixelInitialized', {}]); </script>
	<noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=413375698823dd720&ev=PixelInitialized" /></noscript>

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
            
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p8iHsI-2r',
            title: 'Why the March for Our Lives will be a missed opportunity',
            templates: {
                twitter: '{{title}}: {{url}} (via @john_e_floyd)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow The Right Way:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'writerjohnfloyd'},
            {'service': 'twitter', 'id': 'john_e_floyd'},
            {'service': 'rss', 'id': 'https://johnfloyd.bangordailynews.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "why-the-march-for-our-lives-will-be-a-missed-opportunity";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['The Right Way', 'politics', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Why the March for Our Lives will be a missed opportunity" />
<meta property="og:url" content="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" />
<meta property="og:description" content="Tomorrow, high-school students will partake in exercising one of the most important of the Bill of Rights, to assemble and petition their government, demanding that Congress pass a host of new gun …" />
<meta property="article:published_time" content="2018-03-23T18:50:53+00:00" />
<meta property="article:modified_time" content="2018-03-23T19:46:18+00:00" />
<meta property="og:site_name" content="The Right Way" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="639" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@bdnmaineblogs" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@john_e_floyd" />

    <script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-5329647-1', 'auto');        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('send', 'pageview', {
            'dimension1': 'John Floyd','dimension2': 'post','dimension3': '468.151','dimension5': 'politics',				'dimension10': '2',
				 
				'dimension11' : 'Congress,gun bans,gun rights,March for Our Lives,school shootings'

				        }); //ga send

        /**
         * UA-5329647-52 is the id for the new rollup property
         * It is normally only used in the GTM container. It needs to be added here to be able to send video events
         * direct to the property because the current GTM container is not included on mobile.
         */
        ga('create', 'UA-5329647-52', 'auto', 'rollup4video');
    </script>

			<script>

		/**
		* Function that tracks a click on an outbound link in Google Analytics.
		* This function takes a valid URL string as an argument, and uses that URL string
		* as the event label. Setting the transport method to 'beacon' lets the hit be sent
		* using 'navigator.sendBeacon' in browser that support it.
		 * 
		 * @see https://support.google.com/analytics/answer/1136920?hl=en
		*/
		jQuery(function() {
			jQuery('.entry p a').on( 'click', function() {
				ga('send', 'event', 'in-article click', '468.151', jQuery(this).attr('href'), {
				  'transport': 'beacon'
				});
			});
		});

		
		jQuery(function($) {
		    // Default time delay before checking location
		    var callBackTime = 100;

		    // # px before tracking a reader
		    var readerLocation = 150;

		    // Set some flags for tracking & execution
		    var timer = 0;
		    var scroller = false;
		    var endContent = false;
		    var didComplete = false;

		    // Set some time variables to calculate reading time
		    var startTime = new Date();
		    var beginning = startTime.getTime();
		    var totalTime = 0;

		    // Get some information about the current page
		    var pageTitle = '468.151';

		    // Track the aticle load
	        ga('send', 'event', 'Reading', 'ArticleLoaded', pageTitle, {'nonInteraction': 1});


		    // Check the location and track user
		    function trackLocation() {
		        bottom = jQuery(window).height() + jQuery(window).scrollTop();
		        height = jQuery(document).height();

		        // If user starts to scroll send an event
		        if (bottom > readerLocation && !scroller) {
		            currentTime = new Date();
		            scrollStart = currentTime.getTime();
		            timeToScroll = Math.round((scrollStart - beginning) / 1000);

		            ga('send', 'event', 'Reading', 'StartReading', pageTitle, timeToScroll);
		            scroller = true;
		        }

		        // If user has hit the bottom of the content send an event
		        if (bottom >= jQuery('.entry').offset().top + jQuery('.entry').innerHeight() && !endContent) {
		            currentTime = new Date();
		            contentScrollEnd = currentTime.getTime();
		            timeToContentEnd = Math.round((contentScrollEnd - scrollStart) / 1000);
		            ga('send', 'event', 'Reading', 'ContentBottom', pageTitle, timeToContentEnd);
		            endContent = true;
		        }

		        // If user has hit the bottom of page send an event
		        if (bottom >= height && !didComplete) {
		            currentTime = new Date();
		            end = currentTime.getTime();
		            totalTime = Math.round((end - scrollStart) / 1000);

	                if (totalTime < 60) {
	                	ga('set', 'dimension8', 'Scanner');
	                } else {
	                	ga('set', 'dimension8', 'Reader');
	                }

	                ga('send', 'event', 'Reading', 'PageBottom', pageTitle, totalTime);
		            didComplete = true;
		        }
		    }

		    // Track the scrolling and track location
		    jQuery(window).scroll(function() {
		        if (timer) {
		            clearTimeout(timer);
		        }

		        // Use a buffer so we don't call trackLocation too often.
		        timer = setTimeout(trackLocation, callBackTime);
		    });


		});

		</script>

	

    	<!-- Google Tag Manager -->
	<script type="text/javascript">
		window.dataLayer = window.dataLayer || [];
		window.dataLayer.push({"event":"dataLayer-loaded","companyName":"Bangor Daily News","contentType":"article","author":"John Floyd","contentPublishedDate":"2018-03-23","contentPublishedTime":"2018-03-23 14:50:53-04:00","lastUpdatedTime":"2018-03-23 15:46:18-04:00","primaryCategory":"Guns","allCategories":"Guns|Home|U.S."});
	</script>

	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-W3QLSF');</script>
	<!-- End Google Tag Manager -->

<!-- mather listener tag -->
    <script type="text/javascript">
        /**
         * Retrieve specific cookie val
         * @param name
         * @returns {null}
         */
        function getCookie(name)
        {
            var re = new RegExp(name + "=([^;]+)");
            var value = re.exec(document.cookie);
            return (value != null) ? unescape(value[1]) : null;
        }

        (function () {
            var _matherq;
            var loadSp;

            try {
                _matherq = window.top._matherq;
            }
            catch (e) { }

            if (!_matherq) {
                _matherq = (window._matherq = window._matherq || []);
                loadSp = true;
            }

            _matherq.push(['setCollectorUrl', 'www.i.matheranalytics.com']);
            _matherq.push(['setAppId', 'v1']);
            _matherq.push(['setCustomerId', 'ma63069']);
            _matherq.push(['setMarket', '92760912']);
            _matherq.push(['setUserId', getCookie('wpuid')]);
            _matherq.push(['setSection', (dataLayer[0].primaryCategory || dataLayer[0].contentType || '').replace(/^section-/i, '')]);            
            _matherq.push(['setAuthor', dataLayer[0].author]);
            _matherq.push(['setPageType', dataLayer[0].contentType]);
            _matherq.push(['setArticlePublishTime', dataLayer[0].lastUpdatedTime]);
            _matherq.push(['enableActivityTracking', 30, 10]);
            _matherq.push(['trackPageView', null, { category: { categories: [[(dataLayer[0].allCategories || '').replace(/\|/g, ',')]] }} ]);

            if (loadSp) {
                var a = [].concat.apply([], _matherq);
                var src = a[a.indexOf('setCustomerId') + 1] + '/' + a[a.indexOf('setMarket') + 1] + '/sp.js?cb=' + Math.round(new Date() / 1.0368e9);
                var sp = document.createElement('script'); sp.type = 'text/javascript'; sp.async = true; sp.defer = true;
                sp._mather_tag = document.scripts[document.scripts.length - 1]; sp._mather_sp = sp.uniqueID;
                sp.src = ('https:' == document.location.protocol ? 'https' : 'http') + '://js.matheranalytics.com/s/' + src;
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sp, s);
            }
        })();
    </script>
    <noscript><img src="http://www.i.matheranalytics.com/i?e=pv&aid=v1&cid=ma63069&mrk=92760912&p=web&tv=no-js-0.1.0&tid=1521963892" style="display:none" height="1" width="1" alt/></noscript>


	<script type="text/javascript">
	var BdnAdsCommandArray = new Array();
	</script>
</head>

<body class="post-template-default single single-post postid-151 single-format-standard single-author sidebar">
    <div id="page" class="hfeed site">
	<header class="site-header" role="banner">
	    <div class="bdn-banner">
		
		
		<ul class="bdn-nav">
		    <li>
			<a href="http://www.bangordailynews.com" class="bdn-flag">
			<img src="https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg"s />
			<!--<h3>Bangor Daily News</h3>-->
		    </a>
		    </li>
		    <!--<li><a href="http://bangordailynews.com/">News</a></li><span>|</span>-->	
		    <li><a href="http://bangordailynews.com/politics/">Politics</a></li><span>|</span>	
		    <li><a href="http://bangordailynews.com/business/">Business</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/health">Health</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/homestead/">Homestead</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/food/">Food</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/events/">Events</a></li><span>|</span>
		    <li><a href="http://bangordailynews.com/opinion/">Opinion</a></li>
		</ul>
		
	    </div>
	    
	    <div class="home-link">
		    <a href="https://johnfloyd.bangordailynews.com/"
		       title="The Right Way" rel="home">
			    <div class="blog-headshot"
			         style="background: url('https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/01/BW-Headshot.jpg') no-repeat center center;
				         background-size: cover;">
				    The Right Way			    </div>
			    <div class="site-headers">
				    <h1 class="site-title">The Right Way</h1>
				    <h2 class="site-description">John Floyd</h2>
			    </div>
		    </a>
		    <a class="bdn-link"
		       href="http://bangordailynews.com/maine-blogs/?utm_source=The+Right+Way&utm_medium=footer">
			    <img src="https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
			         title="BDN Maine"/>
		    </a>
	    </div><!-- /.home-link -->

		<div id="navbar" class="navbar">
			<nav id="site-navigation" class="navigation main-navigation" role="navigation">
				<h3 class="menu-toggle">Menu</h3>
				<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
				<div class="menu-default-menu-container"><ul id="menu-default-menu" class="nav-menu"><li id="menu-item-72" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-72"><a href="https://johnfloyd.bangordailynews.com/category/home/">Home</a></li>
<li id="menu-item-73" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-73"><a href="https://johnfloyd.bangordailynews.com/category/us/">U.S.</a></li>
<li id="menu-item-74" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74"><a href="https://johnfloyd.bangordailynews.com/category/maine/">Maine</a></li>
<li id="menu-item-8" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8"><a href="https://johnfloyd.bangordailynews.com/contact/">Contact</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14"><a href="https://johnfloyd.bangordailynews.com/about/">About</a></li>
</ul></div>				<form role="search" method="get" id="searchform" class="search-form" action="https://johnfloyd.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>			</nav><!-- #site-navigation -->
		</div><!-- #navbar -->
	</header><!-- #masthead -->

	    	                <div class="adSpot widget">
			                        <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
			                </div>
	    
	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-151" class="post-151 post type-post status-publish format-standard has-post-thumbnail hentry category-guns category-home category-us tag-congress tag-gun-bans tag-gun-rights tag-march-for-our-lives tag-school-shootings">
	<header class="entry-header">
		
            <h1 class="entry-title">Why the March for Our Lives will be a missed opportunity</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" title="Permalink to Why the March for Our Lives will be a missed opportunity" rel="bookmark"><time class="entry-date" datetime="2018-03-23T14:50:53+00:00">March 23, 2018</time></a></span><span class="categories-links"><a href="https://johnfloyd.bangordailynews.com/category/guns/" rel="category tag">Guns</a>, <a href="https://johnfloyd.bangordailynews.com/category/home/" rel="category tag">Home</a>, <a href="https://johnfloyd.bangordailynews.com/category/us/" rel="category tag">U.S.</a></span><span class="tags-links"><a href="https://johnfloyd.bangordailynews.com/tag/congress/" rel="tag">Congress</a>, <a href="https://johnfloyd.bangordailynews.com/tag/gun-bans/" rel="tag">gun bans</a>, <a href="https://johnfloyd.bangordailynews.com/tag/gun-rights/" rel="tag">gun rights</a>, <a href="https://johnfloyd.bangordailynews.com/tag/march-for-our-lives/" rel="tag">March for Our Lives</a>, <a href="https://johnfloyd.bangordailynews.com/tag/school-shootings/" rel="tag">school shootings</a></span>					    <div class="author-byline">
			By <a href="https://johnfloyd.bangordailynews.com/author/lifeontheridge/" title="Posts by John Floyd" rel="author">John Floyd</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Why the March for Our Lives will be a missed opportunity."
               data-url="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/"
               data-via='john_e_floyd'               data-related="john_e_floyd,bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-250x250.jpg&description=Why the March for Our Lives will be a missed opportunity" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720.jpg"><img class="aligncenter size-large wp-image-153" src="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-600x399.jpg" alt="" width="600" height="399" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-600x399.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-450x300.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-768x511.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>Tomorrow, high-school students will partake in exercising one of the most important of the Bill of Rights, to assemble and petition their government, demanding that Congress pass a host of new gun control legislation in the wake of the school shooting in Parkland, Florida. The fact that they are exercising one constitutional right to seek infringement of another is an irony I am sure is lost on them.</p>
<p>On March 24, 2018 the <a href="https://marchforourlives.com/" target="_blank" rel="noopener">March for Our Lives</a> movement will pour into Washington D.C. in an effort to ban lawfully-owned firearms, accessories, and to lobby for the implementation of universal background checks for every single gun sale – with no exceptions.</p>
<p>These are the stated positions in the <a href="https://marchforourlivespetition.com/" target="_blank" rel="noopener">petition</a> on the March for Our Lives website, which is worded with many of the same talking points, misinformation, and outright lies gun-grabbing politicians have used for years. It is quite apparent that what may have started as a grass-roots movement by scared kids with justified fears quickly became gobbled up by self-serving interests – anti-gun activists and politicians.</p>
<p>For example, the <a href="https://www.cnn.com/2018/02/15/opinions/florida-shooting-no-more-opinion-kasky" target="_blank" rel="noopener">CNN Op-Ed</a> piece by march organizer and Parkland student Cameron Kasky is a carefully crafted political hit piece complete with the obligatory finger pointing at Republicans and the NRA while mocking &#8220;family values&#8221; and &#8220;some of these people (who) stockpile guns in advance of a gun ban&#8221;.</p>
<p>Do you really believe, even for a minute, that there wasn&#8217;t any coaching going on when that opinion piece was written?</p>
<p>The impression, while listening to the majority of major media outlet reports, is that this was a grass-roots movement formed by kids demanding action to keep them safe in school.  As it turns out, this is just another case of “fake news”. This is no student groundswell folks, not anymore.</p>
<p>How else do you explain the formation of a <a href="https://www.irs.gov/charities-non-profits/other-non-profits/types-of-organizations-exempt-under-section-501c4" target="_blank" rel="noopener">501(c)4</a> political non-profit, a <a href="https://www.gofundme.com/8psm8-march-for-our-lives" target="_blank" rel="noopener">$3.4 million dollar war chest</a>, and a multi-tiered social media platform complete with a <a href="https://marchforourlivespetition.com/" target="_blank" rel="noopener">call to action petition</a>? Am I to believe that a bunch of high school students were able to form and organize a political machine such as this in several weeks?</p>
<p>Some issues I&#8217;d expect these kids to be adamant about aren&#8217;t even touched on. There is not a single mention in the petition about improving school security, mental health issues or the complete lack of accountability by law enforcement at several levels who failed to act, and multiple times at that – actions that may have prevented numerous deaths.</p>
<p>Not a mention about real change, policy points or actionable ideas can be found anywhere in the movements literature. What these kids are marching for is just your garden variety gun ban. And that is a real missed opportunity.</p>
<p>Why?</p>
<p>Because these kids have the country’s attention, that’s why. If there was ever a time to force the issue of protecting our schools like we protect sports stadiums, banks and courthouses, now is the time.</p>
<p><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720.jpg"><img class="aligncenter size-large wp-image-154" src="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720-600x224.jpg" alt="" width="600" height="224" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720-600x224.jpg 600w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720-450x168.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720-768x287.jpg 768w, https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/baseball-field-1149153_960_720.jpg 960w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<p>They could be making real progress in shaming our elected politicians, instead of law-abiding citizens, into finally hardening our schools to a level of protection they themselves enjoy and forcing critical missteps by law enforcement agencies into the light. But alas, any chance of real reform in school security policy and the safety of our kids went right out the window as soon as the career activists got involved.</p>
<p>As an NRA lifetime member, certified firearms instructor and veteran, you may think I’m angry at these kids; angry at the fact they are championing a long held liberal cause to ban firearms and to recognize the validity of the Bill of Rights selectively, only as it fits their purpose.</p>
<p>But you would be wrong. Mostly, I feel an aching sadness for them &#8211; for what has happened to them in the past and what is happening to them right now.</p>
<p>You see, I know who appropriated this movement. I know who snatched the reins from these kids and told them “Great job kids, but we’ll take it from here.” I know who has been whispering in their ear about what a <em>great change </em>they will be responsible for and how <em>history will remember them</em>. I know who is lying to them.</p>
<p>These kids deserve better than to be treated as pawns and have their very real concerns and fears politicized for ideology. Instead of making any real progress on the security of our schools and keeping our kids safe, anti-gun politicians in Congress are treating the March for Our Lives as just another political game.</p>
<p>Here is my prediction for tomorrow’s score: Anti-gun Ideologues and Politicians &#8211; 1 School Security and Kids Safety &#8211; 0</p>
<p>And that is shameful.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-text="Why the March for Our Lives will be a missed opportunity" data-via="john_e_floyd" >Tweet</a></li><li class="share-facebook"><div class="fb-share-button" data-href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-layout="button_count"></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fjohnfloyd.bangordailynews.com%2F2018%2F03%2F23%2Fhome%2Fwhy-the-march-for-our-lives-will-be-a-missed-opportunity%2F&#038;media=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F468%2Ffiles%2F2018%2F03%2Fcapital-hill-2645396_960_720.jpg&#038;description=Why%20the%20March%20for%20Our%20Lives%20will%20be%20a%20missed%20opportunity" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/"></div></div></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button" href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-counter="right"></script></div></li><li class="share-tumblr"><a target="_blank" href="https://www.tumblr.com/share/link/?url=https%3A%2F%2Fjohnfloyd.bangordailynews.com%2F2018%2F03%2F23%2Fhome%2Fwhy-the-march-for-our-lives-will-be-a-missed-opportunity%2F&name=Why%20the%20March%20for%20Our%20Lives%20will%20be%20a%20missed%20opportunity" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('https://platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li class="share-end"></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=https%3A%2F%2Fjohnfloyd.bangordailynews.com%2F2018%2F03%2F23%2Fhome%2Fwhy-the-march-for-our-lives-will-be-a-missed-opportunity%2F&amp;title=Why%20the%20March%20for%20Our%20Lives%20will%20be%20a%20missed%20opportunity" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-press-this"><a rel="nofollow" data-shared="" class="share-press-this sd-button" href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/?share=press-this" target="_blank" title="Click to Press This!"><span>Press This</span></a></li><li class="share-end"></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-end"></li></ul></div></div></div></div></div>
		</div>
			
			<script type="text/javascript">
  try { _402_Show(); } catch(e) {}
</script>
	
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Why the March for Our Lives will be a missed opportunity."
               data-url="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/"
               data-via='john_e_floyd'               data-related="john_e_floyd,bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-250x250.jpg&description=Why the March for Our Lives will be a missed opportunity" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    				                    
<div class="author-info">
	<div class="author-avatar">
			    <img src="http://gravatar.com/avatar/64979cf70f32fbcf25c7ac15d1b719c0?s=74&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F468%2Ffiles%2F2018%2F01%2FBW-Headshot.jpg"
		 alt="John Floyd"
		 title="John Floyd"
		 class="gravatar avatar"
		 align="left"
		 width="74" 
		 height="74" 
		 />
	</div><!-- .author-avatar -->
	<div class="author-description">
		<h2 class="author-title">About John Floyd</h2>
		<p class="author-bio">
			John is a freelance writer and lives in northeast Maine. His background includes work as a hunting and fishing guide, certified firearms instructor and as a United States Army Non-commissioned Officer. He covers outdoors topics and the politics and policies that affect traditional, rural lifestyle. He can be reached at john@tuckerridge.me or on Facebook @writerjohnfloyd                    
                        		</p>
	</div><!-- .author-description -->
</div><!-- .author-info -->		    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="https://johnfloyd.bangordailynews.com/2018/02/26/home/bump-stocks-are-the-new-red-herring-of-school-safety-failures/" rel="prev"><span class="meta-nav">&larr;</span> Why banning bump stocks in Maine is a fraud</a>			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "john@tuckerridge.me", 
                                post_title : "Why the March for Our Lives will be a missed opportunity", 
                                post_link : "https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/", 
                                post_id : "151"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-2" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>John Floyd</h3>
                    <a class="author-avatar" href="http://writerjohnfloyd.tuckerridge.me">
                        <img src="http://gravatar.com/avatar/64979cf70f32fbcf25c7ac15d1b719c0?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F468%2Ffiles%2F2018%2F01%2FBW-Headshot.jpg"
                             alt="John Floyd"
                             title="John Floyd"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                        John is a freelance writer and lives in northeast Maine. His background includes work as a hunting and fishing guide, certified firearms instructor and as a United States Army Non-commissioned Officer. He covers outdoors topics and the politics and policies that affect traditional, rural lifestyle. He can be reached at john@tuckerridge.me or on Facebook @writerjohnfloyd                    </p>
                    
                                            <a href="https://twitter.com/john_e_floyd" class="twitter-follow-button" data-show-count="true">
                            Follow @john_e_floyd                        </a>
                        <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
                                        
                                            <div class="fb-like-box" 
                             data-href="https://www.facebook.com/writerjohnfloyd"
                             data-width="300" 
                             data-show-faces="false" 
                             data-header="false" 
                             data-stream="false" 
                             data-show-border="false">
                        </div>
                    
                                        
                    
                </div>
                
        </h3></aside><aside id="rss-2" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="http://writerjohnfloyd.tuckerridge.me"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://johnfloyd.bangordailynews.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://writerjohnfloyd.tuckerridge.me/">John Floyd &#8211; RSS feed</a></h3><ul><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/03/19/is-it-time-to-change-the-way-we-talk-about-hunting/'>Is it time to change the way we talk about hunting?</a> <span class="rss-date">March 19, 2018</span></li><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/02/26/bump-stocks-are-the-new-red-herring-of-school-safety-failures/'>Bump stocks are the new red herring of school safety failures</a> <span class="rss-date">February 26, 2018</span></li><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/02/20/i-am-the-nra/'>I am the NRA</a> <span class="rss-date">February 20, 2018</span></li><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/02/19/how-i-cut-the-cord-and-why-i-never-looked-back/'>How I cut the cord and why I never looked back</a> <span class="rss-date">February 19, 2018</span></li><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/02/15/guns-are-not-the-problem-america-you-are/'>Guns are not the problem America, you are</a> <span class="rss-date">February 15, 2018</span></li><li><a class='rsswidget' href='http://writerjohnfloyd.tuckerridge.me/blog/2018/02/06/committee-to-hunters-you-dont-have-the-right-to-feed-your-family/'>Committee to hunters: You don’t have the right to feed your family</a> <span class="rss-date">February 6, 2018</span></li></ul></aside>        <div class="bdn-blogs-widget widget category-politics">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=The+Right+Way&utm_source=politics-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=The+Right+Way&utm_source=politics-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: politics -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://educationfutureimperfect.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="Contemporary perspectives on education">
						Education:  Future Imperfect                    </a>
                </h5>

				                    <!-- Image from image
                    Syndicate https://bdn-data.s3.amazonaws.com/blogs.dir/129/files/2012/11/howardsegal_headshotsmall.jpg                    Image https://bdn-data.s3.amazonaws.com/blogs.dir/129/files/2012/11/howardsegal_headshotsmall.jpg                    Blog Image http://educationfutureimperfect.bangordailynews.com/files/2012/11/howardsegal_headshotsmall.jpg                    -->
                    <a
                            class="post-image"
                            style="background-image:url('https://bdn-data.s3.amazonaws.com/blogs.dir/129/files/2012/11/howardsegal_headshotsmall.jpg'); background-position: center center; background-size: contain; background-color: rgb(90, 129, 170);"
                            href="http://educationfutureimperfect.bangordailynews.com/2018/03/24/can-the-bangor-schools-administration-stop-the-media-from-covering-todays-student-protests/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="Can the Bangor Schools administration stop the media from covering today's student protests?">

						Education:  Future Imperfect                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://educationfutureimperfect.bangordailynews.com/2018/03/24/can-the-bangor-schools-administration-stop-the-media-from-covering-todays-student-protests/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						Can the Bangor Schools administration stop the media from covering today's student protests?                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_2" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://weilsnotes.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="News that affects Mainers">
						Notes from a Corner of the Country                    </a>
                </h5>

				                    <!-- Image from image
                    Syndicate https://bdn-data.s3.amazonaws.com/blogs.dir/200/files/2013/12/GLW-Media-300x300.jpg                    Image https://bdn-data.s3.amazonaws.com/blogs.dir/200/files/2013/12/GLW-Media-300x300.jpg                    Blog Image                     -->
                    <a
                            class="post-image"
                            style="background-image:url('https://bdn-data.s3.amazonaws.com/blogs.dir/200/files/2013/12/GLW-Media-300x300.jpg'); background-position: center center; background-size: contain; background-color: rgb(90, 129, 170);"
                            href="http://weilsnotes.bangordailynews.com/2018/03/24/home/internet-social-media-become-weapons-of-war/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="Internet, social media become weapons of war">

						Notes from a Corner of the Country                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://weilsnotes.bangordailynews.com/2018/03/24/home/internet-social-media-become-weapons-of-war/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						Internet, social media become weapons of war                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_3" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://johnfloyd.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="John Floyd">
						The Right Way                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/468/files/2018/03/capital-hill-2645396_960_720-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="Why the March for Our Lives will be a missed opportunity">
						Why the March for Our Lives will be a missed opportunity                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						Why the March for Our Lives will be a missed opportunity                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_4" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://stateandcapitol.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="Maine politics — as it happens">
						State &amp; Capitol                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/23/files/2018/03/10024841_H7482335-600x395-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://stateandcapitol.bangordailynews.com/2018/03/23/more-investigations-loom-for-busy-maine-government-watchdog/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="More investigations loom for busy Maine government watchdog">
						More investigations loom for busy Maine government watchdog                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://stateandcapitol.bangordailynews.com/2018/03/23/more-investigations-loom-for-busy-maine-government-watchdog/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						More investigations loom for busy Maine government watchdog                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_5" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://cianchette.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="Michael Cianchette on Maine Politics">
						He Said It Right                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/256/files/2018/03/BIZ-TESLA-MUSK-PAY-ABA_22983526-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://cianchette.bangordailynews.com/2018/03/23/commentary/how-much-would-tesla-pay-a-governor/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="How much would Tesla pay a governor?">
						How much would Tesla pay a governor?                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://cianchette.bangordailynews.com/2018/03/23/commentary/how-much-would-tesla-pay-a-governor/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						How much would Tesla pay a governor?                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_6" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://pinetreepolitics.bangordailynews.com/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank title="Political Intrigue from the state of Maine">
						Pine Tree Politics                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/53/files/2018/03/BRITAIN_FACEBOOK_CAMBRIDGE_ANALYTICA_22982450-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://pinetreepolitics.bangordailynews.com/2018/03/21/privacy-politics-and-facebook-data/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                            title="Privacy, politics and Facebook data">
						Privacy, politics and Facebook data                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://pinetreepolitics.bangordailynews.com/2018/03/21/privacy-politics-and-facebook-data/?utm_campaign=The+Right+Way&utm_source=politics-widget"
                       target=_blank>
						Privacy, politics and Facebook data                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.007015 seconds to load. -->
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="archives-3" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='https://johnfloyd.bangordailynews.com/2018/03/'>March 2018</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2018/02/'>February 2018</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2017/10/'>October 2017</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2017/04/'>April 2017</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2017/03/'>March 2017</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2017/02/'>February 2017</a></li>
	<li><a href='https://johnfloyd.bangordailynews.com/2017/01/'>January 2017</a></li>
		</ul>
		</aside><aside id="blog_subscription-2" class="widget jetpack_subscription_widget"><h3 class="widget-title">Subscribe to Blog via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div><p>Join 45 other subscribers</p>
					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-2">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-2" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://johnfloyd.bangordailynews.com/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-2]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-2'),
					input = d.getElementById('subscribe-field-blog_subscription-2'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="rss_links-2" class="widget widget_rss_links"><ul><li><a target="_self" href="https://johnfloyd.bangordailynews.com/feed/" title="Subscribe to Posts">RSS - Posts</a></li><li><a target="_self" href="https://johnfloyd.bangordailynews.com/comments/feed/" title="Subscribe to Comments">RSS - Comments</a></li></ul>
</aside><aside id="search-3" class="widget widget_search"><form role="search" method="get" id="searchform" class="search-form" action="https://johnfloyd.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside><aside id="text-2" class="widget widget_text">			<div class="textwidget"><div role="form" class="wpcf7" id="wpcf7-f5-o1" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/#wpcf7-f5-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="5" />
<input type="hidden" name="_wpcf7_version" value="4.7" />
<input type="hidden" name="_wpcf7_locale" value="" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f5-o1" />
<input type="hidden" name="_wpnonce" value="f3ca63c7d3" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" size="40" class="wpcf7-form-control wpcf7-text" aria-invalid="false" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" cols="40" rows="10" class="wpcf7-form-control wpcf7-textarea" aria-invalid="false"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=The+Right+Way&utm_medium=footer">
                                <img src="https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                The Right Way is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

		<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/johnfloyd.bangordailynews.com\/2018\/03\/23\/home\/why-the-march-for-our-lives-will-be-a-missed-opportunity\/":151};
	</script>
			<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
					<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
				<div id="sharing_email" style="display: none;">
		<form action="/2018/03/23/home/why-the-march-for-our-lives-will-be-a-missed-opportunity/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type="text/javascript">
			jQuery( document ).ready( function() {
				jQuery.getScript( 'https://platform.linkedin.com/in.js?async=true', function success() {
					IN.init();
				});
			});
			jQuery( document.body ).on( 'post-load', function() {
				if ( typeof IN != 'undefined' )
					IN.parse();
			});
			</script><script type="text/javascript" src="https://platform.tumblr.com/v1/share.js"></script>		<script>
		// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
		function jetpack_sharing_pocket_init() {
			jQuery.getScript( 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
		}
		jQuery( document ).ready( jetpack_sharing_pocket_init );
		jQuery( document.body ).on( 'post-load', jetpack_sharing_pocket_init );
		</script>
		<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201812'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/johnfloyd.bangordailynews.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://johnfloyd.bangordailynews.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.8.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

    <!-- ChartBeat -->
    <script type='text/javascript'>
        var _sf_async_config={uid:14550,domain:"bangordailynews.com",useCanonical:true};
    </script>

    		<script type="text/javascript" src="https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/js/chartbeat.js">
    
	<script type="text/javascript">
		var oldonload = window.onload;
		window.onload = (typeof window.onload != 'function') ?
		loadChartbeat : function() { oldonload(); loadChartbeat(); };
	</script>

<script type='text/javascript' src='https://stats.wp.com/e-201812.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'122667664',post:'151',tz:'-4',srv:'johnfloyd.bangordailynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '122667664', '151' ]);
</script>

   <script type="text/javascript">
   	var $mcGoal = {'settings':{'uuid':'a629a44de37af801f63b7384a','dc':'us1'}};
   	(function() {
   		 var sp = document.createElement('script'); sp.type = 'text/javascript'; sp.async = true; sp.defer = true;
   		sp.src = ('https:' == document.location.protocol ? 'https://s3.amazonaws.com/downloads.mailchimp.com' : 'http://downloads.mailchimp.com') + '/js/goal.min.js';
   		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(sp, s);
   	})();
   </script>

</body>
</html>
